No announcement yet.

Cần giúp đỡ vấn đề chia sẻ trong mạng LAN

  • Lọc
  • Giờ
  • Show
Clear All
new posts

  • Cần giúp đỡ vấn đề chia sẻ trong mạng LAN

    Đầu tuần rồi em có chạy tool check Wanna Cry của BKAV và thực hiện theo hướng dẫn này.
    A.Kiểm tra port 445
    Mở CMD quyền Admin và gõ
    netstat -an | findstr 445
    Nếu gõ không hiện ra cái gì thì là OK còn nếu có chữ LISTENNING thì phải block port ngay
    B. Tắt SMB (Mở Powershell lên và oánh các lệnh sau)
    Mở Start-> Windows PowerShell-> Phải chuột vào Windows Powershell chọn Run as administrator
    Copy từng dòng Paste vào. Nếu nó hiện lỗi gì thì bỏ qua sang dòng khác
    Remove-WindowsFeature FS-SMB1
    Disable-WindowsOptionalFeature -Online -FeatureName smb1protocol
    sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
    sc.exe config mrxsmb10 start= disabled
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled
    Set-SmbServerConfiguration -EnableSMB2Protocol $false
    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanSer ver\Parameters" SMB2 -Type DWORD -Value 0 -Force
    B. Chặn port 445/137/138/139 trên Firewall
    Máy nào cài Antivirus mà có tường lửa riêng thì phải cấu hình trên tường lửa riêng
    của Anivirus
    Còn máy nào ko xài Antivirus hoặc Windows Defener thì làm như sau
    B1: Mở Start search cụm từ Firewall và chọn Windows Firewall with Advanced security
    B2: Inbound Rules-> New Rule-> Port
    B3: Chọn UDP-> Specific local ports nhập dòng này vào 445,137,138,139
    B4: Block the connection
    B5: Tick cả 3 cái
    B6: Đặt tên tùy ý-> finish
    B7: Kiểm tra lại xem bật firewall chưa, chưa thì bật lên
    C. Tắt Sever service
    B1: Run-> Services.msc
    B2: Tìm tới Services Server. Phải chuột chọn Stop
    B3: Click đúp vào nó. Startup type sửa thành Disabled. Apply->OK
    Sau khi làm xong tất cả RESTART LẠI MÁY

    Giờ em cài lại để chia sẻ các máy trong mạng LAN mà không được. Em đã bỏ chặn các port trên Firewall, chạy lại Services Server. Lúc vào chọn Share File and print ON và save thì tự động nó OFF. Em nghỉ chắc do SMB ở bước B mà không biết khắc phục bằng cách nào. Mong được giúp đỡ.
    Xin chân thành cảm ơn.

  • #2
    Mong được mọi người giúp đỡ

    Comment


    • #3
      Mình nhớ là Bkav Forum chưa từng có hướng dẫn nào như thế này cả. Bạn thử vào Control Panel >> Turn Windows Features On of Off, cài lại SMB xem sao?

      Comment

      Mời bạn bấm like để theo dõi Bkav forum trên Facebook
      X